
Drop-Down Menus

This document describes the TCSGUI drop-down menus that are along the top of the 
TCSGUI.

File Menu:
Open/Transfer Worklists...

Load a new worklist into the TCSMON program. After this occurs, the filename will 
show up under the Next → Worklists menu on the TCSGUI and can then be used for 
selecting the "next" object. Please Note: loading a worklist with more than 900 
objects will cause TCS to crash!

Up to 10 worklists may be loaded.  On loading the 11th worklist, the first worklist loaded
will be overwritten on the menu by the new list.

The worklists files are kept loaded even after exiting and restarting. To clear out the 
worklist entries, use the File → Clear List menu option.

Worklists are files supplied by the user in ASCII (text) format that contain a list of 
predefined objects that the user may wish to point to.  This allows easier  lookups by 
the user for the "Next" object. See Worklists and Ephemerides for format.

Open/Transfer Ephemerides...

Load a new ephemerides file into the TCSMON program.  After this occurs, the 
filename will show up under the Next-→Solar System -->Ephemerides  menu on the 
TCSGUI and can then be used for selecting the "next" object.

Up to 20 ephemerides may be loaded.  On loading the 21st, the first file loaded will be 
overwritten on the menu space by the name of the new file.

The ephemerides are kept loaded even after exiting and restarting.  To clear out the 
ephemerides entries, use the  File → Clear List  menu option.

Ephemerides are generally used for minor planets and comets.   See Ephemerides and
Worklistsfor format.

Open Macro File...
Load a macro file.  This file is then accessed via the Tools → From Macro  popup.

Macro files are ASCII (text) files containing commands in the TCS command language.

A macro file is generally a preprogrammed set of telescope move commands, and can 
make use of more advanced language features like wait time and wait event.
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Open Command File...
Load a command file.  After it is loaded, the name of the file is placed into the 
command file section of the display area of the TCSGUI.

The command scan be accessed and executed via a popup window activated by the 
Tools → Previous Commands or Tools → Manual Commands menu selections.

Command files are ASCII (text) files containing commands in the TCS command 
language.

A command file is generally a list of previously executed TCS commands that was 
created using the File → Save Command History  feature described below.

Save Command History As...
Save the current TCS command history list to a user specified file.

Commands are normally saved by the system to $HOME/.tcsgui.cmd.

Save Object History As...
Save the current TCS object history list to a user specified file.

Objects are normally saved by the system to $HOME/.tcsgui.obj once the system 
moves to that object.

Clear Lists
Clear out all worklists and ephemerides lists.

These lists are normally kept and reloaded when the TCSGUI is restarted. Use this 
command to clear out those lists from the TCS buffers.  Note: This does not delete the 
files from disk.

It is generally a good idea for an observer to execute this command when starting a 
new run to clear out the prior observer's lists.

Clear Previous Objects
Clears the list of previous objects that the TCS has pointed to.

Exit
Exit the TCSGUI.

Note: this does not close out all TCSGUIs running, only the one 'Exit' was selected 
from.  Each TCSGUI must be closed out individually.

This also does not exit the TCSMON program (which normally stays running).

Next Menu:



Next-> Star -> (FK5, BSC)

Choose the"next" object from FK5 catalog or the Yale Bright Star Catalog.

Next -> Star By Name-> (Common Name, Letter + Constellation)
Choose the"next" object by either specifying the common name of a star (e.g."Rigel") 
or by the Greek letter and constellation (e.g. "Beta Orionis").

Next ->FK5 Stars Near Zenith
This command will search for all the FK5 stars located within a specified zenith 
distance and magnitude range.

The popup window allows the user to specify the zenith distance and magnitude limits.

Clicking on Search will initiate the FK5 catalog search for stars matching the specified 
criteria.

After the search is completed, a new window is brought up showing a sky plot of all the
FK5 stars that match the criteria.  A text list is also displayed in the search window.

Clicking on either the "X" in the sky plot or the entry in the text field will place the 
specified star into the "Next" buffer.

NOTE: The sky plot of the stars updates once every 10 minutes.

Next-> BSC Stars Near Zenith
(Yale Bright Star Catalog stars)

This command will search for all stars listed in the Yale Bright Star Catalog within a 
specified zenith distance and magnitude range.

The popup window allows the user to specify the zenith distance and magnitude limits.

Clicking on Search will initiate the BSC catalog search for stars matching the specified 
criteria.

After the search is completed, a new window is brought up showing a sky plot of all the
BSC stars that match the criteria.  A text list is also displayed in the search window.

Clicking on either the "X" in the sky plot or the entry in the text field will place the 
specified star into the next buffer.

NOTE: The sky plot of the stars updates once every 10 minutes.

Next -> Nearby Faint Stars
This command will display a list of "focus" stars close to the current telescope position.

Selecting the desired star and clicking the Apply or OK buttons will enter the star's 
coordinates into the "Next" buffer.



Next -> Nearby BSC Stars
This command will display a list of stars found in the Yale Bright Star Catalog that are 
close to the current telescope position (as opposed to near the zenith).

Selecting the desired star and clicking the Apply or OK buttons will enter the star's 
coordinates into the "Next" buffer.

Next -> Extended Objects -> (NGC, IC, Messier)
Choose the Next object from the NGC, IC or Messier catalog.

Next -> Solar System -> (Planets, Ephemerides, Moon, Sun)
Choose the Next object either from the list of planets, a user supplied ephemeris 
(which must have been loaded previously), the moon, or the sun.

Next -> Worklists
Choose the "Next" object from one of the user specified worklists (which must have 
been loaded previously).

Next-> Manual Entry -> (RA/Dec, HA/Dec, Az/El)
Choose the Next object by specifying the position in either Right 
Ascension/Declination, Hour Angle/Declination or Azimuth/Elevation.

NOTE: when specifying using HA/Dec or Az/El, the tracking will not be enabled.  The 
telescope will move to the position and halt.  To start the tracking choose Next->Start 
Tracking.

Next-> Previous Object
Choose the Next object by selecting the object from the displayed list of objects that 
the system has already pointed to.

Next -> Flat, Stow, Zenith, Start Tracking and Stop Tracking
Choose the Next object as one of the preselected stow positions.  After moving to one 
of these fixed positions, the telescope tracking will be turned off.

To kill the tracking at the current location, choose Next->Stop Tracking .

Tools Menu:
Tools-> Handpaddle Rates

This brings up a popup window that allows the user to change the various movement 
rates for the telescope and to reverse the direction sense of the handpaddle joystick.

NOTE: These are not the track rates.  [Need to include the track rate info somewhere]



Unless you really know what you are doing, you should not adjust any of the rates 
other than the digital step size.

The ranges for each speed are as follows (defaults in bold):
Slew:      0.5 - 0.8  deg/sec   (maximum value)
Search:    0.1 - 0.5  deg/sec   [0.2]
Set:       0.0 - 0.10 deg/sec   [0.5 arcmin/sec]
Guide:     0.0 - 1.0  arcmin/sec[0.99arcsec/sec]
Digital Mode Step size:  0.0 - 60 arcsec [0.30]
Reference Position Rate - 600.00 arcsec/sec

The digital handpaddle mode allows the user to move in discrete increments each time 
the handpaddle joystick is moved.  (e.g. if you wanted to offset to a point 3 arcseconds 
to the north, you could select a step size of 1 arcsec and then toggle the joystick to the 
north 3 times).
You can also use the slider underneath the step size to change the step size.  Step 
sizes greater than 10 arcsecs are not recommended. Use the "offset" computer 
handpaddle for larger moves (select this by clicking on the offset label/button on the 
left side of the TCSGUI.

Selecting the box in front of the RA or DEC "Sign Reversed" will reverse the direction
of all the handpaddle motion in that direction (e.g. swap north-south or east-west 
directions).

The reference position rate is the rate at which the telescope will move when 
changing from one reference position the other.  See Ref1+Ref2 for more information 
on reference positions.

Tools-> Weather Units
This selection allows the user to switch the weather display between English and 
Metric units.

Tools -> Wavelength
This allows the user to modify the wavelength used for the refraction calculations for 
the telescope pointing.  The value used is displayed on the TCSGUI in the upper right 
corner (wave).

Tools -> Enable Dome Automation
Enables/disables dome automation.  A small red box next to this menu item indicates 
that the dome automation system is enabled.  The label of the DomeAz button will also 
have an (AUTO) appended to it when the system is enabled. Note that it will take a few
moments for any dome command to be implemented.

If emergency stop has been hit, the dome automation system will disable.  It will remain
in that state until re-enabled by the user via this menu function.
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When the telescope is sent to the Flat or Stow positions, the dome will automatically be
sent to its park position.  If Zenith is chosen from the next menu, then the user is 
prompted if they wish the dome to go to the park position.

Note: by clicking on the Dome Az button on the TCSGUI, dome offsets may be entered
although they are rarely (if ever) needed under the new dome automation system.

Tools -> Park Dome
This command sends the "Park Dome" command to the 2.7M dome automation 
system.  The dome will move to its park position (dome slit pointed west) and then 
automatically disable the automation.

Observers should leave the dome in this position at the end of each night.

Make sure that you press Emergency Stop when the dome has finished moving to shut
things down at the end of the night.

Tools-> Previous or Manual Command
This command will pop up a window that contains a list of the previously executed 
commands. You can click on any of the commands listed and it will be entered on the 
command line or you can type in the command on the command line.

Clicking on Apply or OK will cause the command line to execute.

Tools -> From Macro File
(This command is currently disabled.)

Tools->From Command File
(This command is currently disabled.)

View Menu:

View-> Sky Plot of Next
This command brings up a sky plot of each successive object chosen from the next 
menu. The plot is cumulative with the latest selection having a cursor superimposed on
it as well as the current telescope position.

Clicking on Clear will clear the cumulative list.

The yellow line on the plot represents the current obstruction mask.

http://snoopy.as.utexas.edu:8080/OS/manuals/2.7m-telescope/tcs/tcsgui/tcsgui-display-screen#section-2


View -> Point
This command displays the calculated and actual positions for the telescope.  The 
positions displayed are:

Mean - raw unprecessed coordinates
Apparent - mean coordinates precessed to the current epoch
Refracted - precessed coordinates that are corrected for atmospheric refraction.

View-> Weather History
This command pops up a window with the the Mt.Locke weather history for the past 24 
hours (or however long the TCSMON has been running).

For monitoring weather conditions, most observers prefer the 'wx' command (issued on
any Mt.Locke Unix system).

See weather for more information about the Mt.Locke weather system as well as other 
helpful weather links. 

Needs updating to John’s new tool – use John’s weather not what is on TCS?

View->Command History
Same as Tools → Previous or Manual Command

View ->Object History
Same as Next → Previous Object

Special Menu:

Many of these are for Mt. Locke only. How do we want to handle these?

http://weather.as.utexas.edu/
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